Pagina de discussões - placas de vídeo Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X]
Using the RX 580 in guix
ciado por marlin1113, 11:34, 25 Maio 2019
Any instructions on the rx580? It says i can use the ATI drivers, but how? At the moment i'm using the vesa graphics with nomodeset on the boot parameters, as it won't work otherwise. I need the 3d accel, but i don't wanna have to use linux vanilla + binary blobs for thar :(
Using the RX 580 in guix
ciado por ambrevar, 12:30, 25 Maio 2019
Things might have changed since 1.0, I'm not sure. Otherwise the default `ati` driver used to run fine. There is also `amdgpu` which worked if I recall correctly. 3D acceleration works, but performance is very poor, so don't expect to run high-end graphics without the binary blob :(
Using the RX 580 in guix
ciado por marlin1113, 12:40, 25 Maio 2019
>Ambrevar I don't mind losing some performance if i can at least get my 580 to work properly. Could you tell me how you managed to get it working when you tried it?
Using the RX 580 in guix
ciado por ambrevar, 12:49, 25 Maio 2019
Nothing, it worked out of the box. What's your issue precisely, doesn't it boot at all? If the kernel boots but X fails to start, you might need one of the xf86-video-amdgpu and xf86-video-ati drivers. If this doesn't help, I recommend you reach out to the Guix mailing list as the AMD stuff has been tweaked recently.
Using the RX 580 in guix
ciado por marlin1113, 12:54, 25 Maio 2019
>ambrevar I basically install the drivers, then modify the xorg-configuration section of config.scm to use the ati drivers. I Boot and it doesn't work (xorg doesn't start, no screen recognized). Same if i use amdgpu instead. I'm trying to get some help on the guix irc channel, if we can't solve it there, i might take a look at the mailing lists
Using the RX 580 in guix
ciado por ambrevar, 13:34, 25 Maio 2019
I didn't modify xorg-configuration in config.scm, there should be no need for it. Can you access a TTY (e.g. with Ctrl-Alt-F2)? If so, look at the output of $ dmesg | grep -i error $ dmesg | grep -i amd $ dmesg | grep -i ati Also see if the driver is properly loaded in $ lspci -k Also see if it works with a different cable. It worked for me over HDMI, maybe it won't with with DisplayPort or vice-versa.
Using the RX 580 in guix
ciado por marlin1113, 13:40, 25 Maio 2019
>ambrevar Here is the output of the commands you told me to use: I'm also using HDMI, ans i have nomodeset enable on the kernel parameters, as the computer won't boot otherwise.
Using the RX 580 in guix
ciado por ambrevar, 13:54, 25 Maio 2019
In lspci, the amdgpu is loaded but not in use, which is strange. I don't use nomodeset. This is probably the issue at play: [drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting. Look up what VGACON does and try disabling it. I'm afraid I can't help much more, but I'm sure some people on the mailing list will be able to help.
Using the RX 580 in guix
ciado por marlin1113, 14:08, 25 Maio 2019
Thanks for the help. I can't seem to find much on vgacon. I'll be asking for help on the bug report mailing list for guix. Hopefully i don't have to use binary firmware.
This is wrong
ciado por kenogo, 04:14, 13 Junho 2019
Hey there, I don't think this entry is correct. @ambrevar Can you please share your output of
lsmod | grep -amdgpu
If it does output something, then you are not using free drivers. As you said yourself in the description, amdgpu depends on binary firmware. That has nothing to do with the xorg drivers, but only with the kernel drivers. Linux-libre simply fails to boot when trying to load amdgpu. You can't substitue the amdgpu kernel driver with the radeon kernel driver, and even that one depends on binary firmware. What kind of CPU do you have? Maybe you're just using integrated graphics? I'm not accusing you of lying, but something isn't right about this.
ciado por kenogo, 04:14, 13 Junho 2019
I obviously meant
lsmod | grep amdgpu
This is correct :)
ciado por ambrevar, 05:11, 13 Junho 2019
I'm running Guix over Linux-libre, without the amdgpu binary blob. Some features do not work (like waking up from hibernation or advanced 3D).
ciado por kenogo, 06:04, 13 Junho 2019
But you are using the amdgpu kernel driver? Mine crashes during boot when trying to load the firmware and complains about the
ciado por kenogo, 06:26, 13 Junho 2019
Okay I finally think I understand what you're talking about. You're not using the amdgpu kernel driver and are simply using ATI as the xorg driver nevertheless, correct?
ciado por ambrevar, 06:35, 13 Junho 2019
Yes, I use the ATI driver.

Write below your motivation is a hardware database project. It runs the h-source PHP software, version SVN-387, available under the GNU General Public (GPLv3) License.
JavaScript license information