Home » Hardware » impresoras » Hewlett-Packard
impresora Hewlett-Packard
modelo: Hewlett-Packard(id del modelo: 1506)
otros posibles nombres del dispositivo:
HP LaserJet Pro MFP M127fw
fabricante:
Hewlett Packard
subtipo (laser, inkjet, ..):
laser
código VendorID:ProductID del dispositivo:
03f0:322a
año de comercialización:
2014
interfaz:
USB
probado con:
Debian GNU/Linux 7 wheezy
probado con el siguiente kernel libre:
3.11-2-amd64
compatibilidad con software libre:
C-Ninguna
¿adopta alguna técnica para rastrear a los usuarios?
no especificado
driver libre usado:
hplip
Descripción:
This does not work with free software, requires additional proprietary firmware from hplip to function as seen below. ... PPD Description: HP LaserJet Pro MFP m127fw, hpcups 3.14.10, requires proprietary plugin ...
    user@localhost ~ $ lsusb
    Bus 005 Device 002: ID 03f0:322a Hewlett-Packard
    user@localhost ~ $ hp-check -r
    Saving output in log file: /home/user/hp-check.log
     
    HP Linux Imaging and Printing System (ver. 3.14.10)
    Dependency/Version Check Utility ver. 15.1
     
    Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.
     
    Note: hp-check can be run in three modes:
    1. Compile-time check mode (-c or --compile): Use this mode before compiling the
    HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
    are installed to successfully compile HPLIP.                                    
    2. Run-time check mode (-r or --run): Use this mode to determine if a distro    
    supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball  
    has the proper dependencies installed to successfully run.                      
    3. Both compile- and run-time check mode (-b or --both) (Default): This mode    
    will check both of the above cases (both compile- and run-time dependencies).  
     
    Check types:                                                                    
    a. EXTERNALDEP - External Dependencies                                          
    b. GENERALDEP - General Dependencies (required both at compile and run time)    
    c. COMPILEDEP - Compile time Dependencies                                      
    d. [All are run-time checks]                                                    
    PYEXT SCANCONF QUEUES PERMISSION                                                
     
    Status Types:
        OK
        MISSING       - Missing Dependency or Permission or Plug-in
        INCOMPAT      - Incompatible dependency-version or Plugin-version
     
    warning: linuxmint-1 version is not supported. Using linuxmint-17 versions dependencies to verify and install...
     
    ---------------
    | SYSTEM INFO |
    ---------------
     
     Kernel: 3.11-2-amd64 #1 SMP Debian 3.11.8-1 (2013-11-13) GNU/Linux
     Host: localhost
     Proc: 3.11-2-amd64 #1 SMP Debian 3.11.8-1 (2013-11-13) GNU/Linux
     Distribution: linuxmint 1
     Bitness: 64 bit
     
     
    -----------------------
    | HPLIP CONFIGURATION |
    -----------------------
     
    HPLIP-Version: HPLIP 3.14.10
    HPLIP-Home: /usr/share/hplip
    warning: HPLIP-Installation: Auto installation is not supported for linuxmint distro  1 version
     
    Current contents of '/etc/hp/hplip.conf' file:
    # hplip.conf.  Generated from hplip.conf.in by configure.
     
    [hplip]
    version=3.14.10
     
    [dirs]
    home=/usr/share/hplip
    run=/var/run
    ppd=/usr/share/ppd/HP
    ppdbase=/usr/share/ppd
    doc=/usr/share/doc/hplip-3.14.10
    html=/usr/share/doc/hplip-3.14.10
    icon=/usr/share/applications
    cupsbackend=/usr/lib/cups/backend
    cupsfilter=/usr/lib/cups/filter
    drv=/usr/share/cups/drv/hp
    bin=/usr/bin
     
    # Following values are determined at configure time and cannot be changed.
    [configure]
    network-build=yes
    libusb01-build=no
    pp-build=no
    gui-build=yes
    scanner-build=yes
    fax-build=yes
    dbus-build=yes
    cups11-build=no
    doc-build=yes
    shadow-build=no
    hpijs-install=no
    foomatic-drv-install=no
    foomatic-ppd-install=no
    foomatic-rip-hplip-install=no
    hpcups-install=yes
    cups-drv-install=yes
    cups-ppd-install=no
    internal-tag=3.14.10
    restricted-build=no
    ui-toolkit=qt4
    qt3=no
    qt4=yes
    policy-kit=no
    lite-build=no
    udev_sysfs_rules=no
    hpcups-only-build=no
    hpijs-only-build=no
     
     
    Current contents of '/var/lib/hp/hplip.state' file:
    [plugin]
    installed = 1
    eula = 1
    version = 3.14.10
     
     
     
    Current contents of '~/.hplip/hplip.conf' file:
    [upgrade]
    notify_upgrade = true
    last_upgraded_time = 1413303245
    pending_upgrade_time = 0
    latest_available_version = 3.14.10
     
    [last_used]
    device_uri = "hpfax:/usb/HP_LaserJet_Pro_MFP_M127fw?serial=CNB8G6FCW2"
    printer_name = HP_LaserJet_Pro_MFP_M127fw_fax
    working_dir = .
     
    [settings]
    systray_visible = 0
    systray_messages = 0
     
    [commands]
    scan = /usr/bin/xsane -V %SANE_URI%
     
    [refresh]
    rate = 30
    enable = false
    type = 1
     
    [polling]
    enable = false
    interval = 5
    device_list =
     
    [fax]
    voice_phone =
    email_address =
     
    [installation]
    date_time = 10/14/2014 13:18:03
    version = 3.14.10
     
     
     <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>
     
    --------------------------
    |  External Dependencies |
    --------------------------
     
     policykit            Admin-Policy-framework    OPTIONAL        -               0.105           OK         -
     gs                   Ghostscript               REQUIRED        7.05            9.05            OK         -
     network              Network-wget              OPTIONAL        -               1.14            OK         -
     scanimage            Shell-Scanning            OPTIONAL        1.0             1.0.23          OK         -
     avahi-utils          avahi-utils               OPTIONAL        -               0.6.31          OK         -
     dbus                 DBus                      REQUIRED        -               1.6.18          OK         -
     cups                 CUPS                      REQUIRED        1.1             1.6.4           OK         'CUPS Scheduler is running'
     xsane                SANE-GUI                  OPTIONAL        0.9             0.998           OK         -
     
    -------------------------
    |  General Dependencies |
    -------------------------
     
     reportlab            Python-PDF-Lib            OPTIONAL        2.0             2.7             OK         -
     libcrypto            OpenSSL-Crypto-Lib        REQUIRED        -               1.0.1           OK         -
     pil                  Python-Image-Lib          OPTIONAL        -               1.1.7           OK         -
     pyqt4-dbus           PyQt4-DBUS                REQUIRED        4.0             4.10.3          OK         -
     libjpeg              JPEG-Lib                  REQUIRED        -               -               OK         -
     libpthread           POSIX-Threads-Lib         REQUIRED        -               2.17            OK         -
     python-dbus          Python-DBUS               REQUIRED        0.80.0          1.2.0           OK         -
     python-devel         Python-SDK                REQUIRED        2.2             2.7.5           OK         -
     pyqt4                Python-Qt4                REQUIRED        4.0             4.10.3          OK         -
     cups-devel           CUPS-SDK                  REQUIRED        -               1.6.4           OK         -
     sane-devel           SANE-SDK                  REQUIRED        -               1.0.23          OK         -
     libusb               USB-Lib                   REQUIRED        -               1.0             OK         -
     sane                 Scan-Lib                  REQUIRED        -               1.0.23          OK         -
     cups-image           CUPS-Image-Lib            REQUIRED        -               1.6.4           OK         -
     libnetsnmp-devel     SNMP-Networking-SDK       REQUIRED        5.0.9           5.7.2           OK         -
     python-xml           Python-XML-Lib            REQUIRED        -               2.1.0           OK         -
     python-notify        Desktop-notifications     OPTIONAL        -               -               OK         -
     
    ----------------------
    |  Python Extentions |
    ----------------------
     
     cupsext              CUPS-Extension            REQUIRED        -               3.14.10         OK         -
     pcardext             PhotoCard-Extension       REQUIRED        -               3.14.10         OK         -
     hpmudext             IO-Extension              REQUIRED        -               3.14.10         OK         -
     
    -----------------------
    |  Scan Configuration |
    -----------------------
     
     hpaio                HPLIP-SANE-Backend        REQUIRED        -               3.14.10         OK         'hpaio found in /etc/sane.d/dll.conf'
     scanext              Scan-SANE-Extension       REQUIRED        -               3.14.10         OK         -
     
    ------------------------------
    | DISCOVERED SCANNER DEVICES |
    ------------------------------
     
    device `hpaio:/usb/HP_LaserJet_Pro_MFP_M127fw?serial=CNB8G6FCW2' is a Hewlett-Packard HP_LaserJet_Pro_MFP_M127fw all-in-one
     
     
    --------------------------
    | DISCOVERED USB DEVICES |
    --------------------------
     
      Device URI                                            Model                            
      ----------------------------------------------------  ----------------------------------
      hp:/usb/HP_LaserJet_Pro_MFP_M127fw?serial=CNB8G6FCW2  HP LaserJet Pro MFP M127fw        
     
    ---------------------------------
    | INSTALLED CUPS PRINTER QUEUES |
    ---------------------------------
     
     
    HP-Officejet-4500-g510g-m
    -------------------------
    Type: Unknown
    Device URI: socket://192.168.001.208:9100
    PPD: /etc/cups/ppd/HP-Officejet-4500-g510g-m.ppd
    PPD Description: HP Officejet 4500 g510g-m, hpcups 3.13.9
    Printer status: printer HP-Officejet-4500-g510g-m is idle.  enabled since Tue 14 Oct 2014 10:08:31 AM EDT
    warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.
     
    HP_LaserJet_Pro_MFP_M127fw
    --------------------------
    Type: Printer
    Device URI: hp:/usb/HP_LaserJet_Pro_MFP_M127fw?serial=CNB8G6FCW2
    PPD: /etc/cups/ppd/HP_LaserJet_Pro_MFP_M127fw.ppd
    PPD Description: HP LaserJet Pro MFP m127fw, hpcups 3.14.10, requires proprietary plugin
    Printer status: printer HP_LaserJet_Pro_MFP_M127fw is idle.  enabled since Tue 14 Oct 2014 12:53:11 PM EDT
    Required plug-in status: Installed
    Communication status: Good
     
    HP_LaserJet_Pro_MFP_M127fw_fax
    ------------------------------
    Type: Fax
    Device URI: hpfax:/usb/HP_LaserJet_Pro_MFP_M127fw?serial=CNB8G6FCW2
    PPD: /etc/cups/ppd/HP_LaserJet_Pro_MFP_M127fw_fax.ppd
    PPD Description: HP Fax2 hpcups
    Printer status: printer HP_LaserJet_Pro_MFP_M127fw_fax is idle.  enabled since Tue 14 Oct 2014 12:53:25 PM EDT
    Required plug-in status: Installed
    Communication status: Good
     
     
    --------------
    | PERMISSION |
    --------------
     
    USB             HP_LaserJet_Pro_MFP_M127fw     Required        -        -        OK       Node:'/dev/bus/usb/005/002' Perm:'  root  lp rw- rw- rw- rw- rw- r--'
     
    -----------
    | SUMMARY |
    -----------
     
    Missing Required Dependencies
    -----------------------------
    None
     
    Missing Optional Dependencies
    -----------------------------
    None
     
     
    Total Errors: 0
    Total Warnings: 1
     
     
    Done.

Write below your motivation

El contenido de esta página está en Dominio Público. (vea la página CC0 para información detallada). Cualquiera es libre de copiar, modificar, publicar, usar, vender o distribuir el texto para cualquier propósito, comercial o no comercial, y por cualquier medio.
h-node.org is a hardware database project. It runs the h-source PHP software, version SVN-387, available under the GNU General Public (GPLv3) License.
JavaScript license information